Can Someone At Roccat Give This a Quick Test? [RESOLVED]

Everything regarding the Power-Grid SDK can be asked and discussed here.

Can Someone At Roccat Give This a Quick Test? [RESOLVED]

Postby Third » 11. May 2015, 08:51

I don't want to publish it and have it bugger up Roccat for anyone.

My Plugin is actually a repository for future state "switches", etc. Rather than build an individual Plugin for every Grid, I intend to publish/update the Plugin separately then use the switches, etc in my existing Grids as well as my projects develop (current and future).

Linked below are the Plugin repository ("Third Plugin v4") and one of my Grids ("PWR v4") that calls that Plugin's switch.

All function 100% normally on my development machine.

My concern is that I got some strange behavior when I pushed this to the test host before publishing. On my "PWR" Grid, it started playing the default Roccat "click1" at the end of every .wav file.

I have since removed "click1" from my from the Plugin, but the "click" continues to play after every .wav file is called.

I've tried uninstalling Power Grid, removing all folders, cleaning the registry entries, rebooting, re-installing Power Grid, but the issue persists on the test host (even without the Plugin being installed). I must be missing something in the removal process.

Oddly, it still functions perfectly normal on my development machine.

I don't want to publish this and have it mess up the sounds in someone else's Grids.

Thanks,

Third

-------------------------

Plugin (with the "click" sound call up removed)
https://www.dropbox.com/s/gwa5209o0mdca ... .rpgp?dl=0

Example Grid using Plugin
https://www.dropbox.com/s/a12yke8959ay5 ... .rpgp?dl=0
Last edited by Third on 12. May 2015, 16:28, edited 7 times in total.
Third
 
Posts: 41
Joined: 20. Apr 2015, 21:58

Re: Can Someone At Roccat Give This a Quick Test?

Postby Third » 12. May 2015, 02:53

The reason I'm concerned is while this build (plugin and seven additional uploads) work fine on my development PC, once I pushed the original Plugin (with click sound) to test hosts BOTH of them started playing the "click" sound at the end of every activation button with a sound associated to it. Not just my Grids, but *everyone's* Grids now have a "click" at the end of the activation sound.

All efforts to remove the issue from the test platforms have failed (and I've tried everything short of a fresh Windows installation).

I don't want to break everyone's Power Grid. I'm hoping that the above Plugin without the "click" resolved the issue (but I cannot confirm it because my two test platforms won't stop playing "clicks" on every user-made grid with sounds).

;)


Third
Third
 
Posts: 41
Joined: 20. Apr 2015, 21:58

Re: Can Someone At Roccat Give This a Quick Test?

Postby Third » 12. May 2015, 03:53

Some further testing with my test platforms that are playing the "click" at the end of each .wav

I temporarily removed the Roccat default sound folder.
(click sounds removed from other users Grids)

Tested my enclosed .wavs to confirm sounds were not altered

Tested in my grids and the "click" is still present at the end of each .wav.

I'm truly puzzled as to where that "click" is coming from now....

Third
Third
 
Posts: 41
Joined: 20. Apr 2015, 21:58

Re: Can Someone At Roccat Give This a Quick Test?

Postby Third » 12. May 2015, 04:05

I guess that I will sort out what corrupted my two test platforms and see if I can find a fix.

What I'm really after here is:

a) someone to "green light" the Plugin in the OP so I can start pushing my grids up to the store.

b) do you hear a mystery "click" at the end of my .waves in the Grid ?

Thanks,

Third
Third
 
Posts: 41
Joined: 20. Apr 2015, 21:58

Re: Can Someone At Roccat Give This a Quick Test?

Postby Third » 12. May 2015, 08:19

I'd really like to be sure this is safe to publish in time for the "Star Citizen Plugin Contest" currently underway. I have four Grids and three Grid Packs awaiting the "ok" to push the Plugin.

Third
Third
 
Posts: 41
Joined: 20. Apr 2015, 21:58

Re: Can Someone At Roccat Give This a Quick Test?

Postby Addihash » 12. May 2015, 12:41

Hello Third,

3 things, first to your problem:

1) I do hear a click at the end of almost every .wav file, but It is not one of our click sounds but rather an error in the file.
And no ohter grid is making sounds where it should not, so i would greenlight this.

2) Be careful with the global variable in the plugin! I know it comes from my code but global variables in Power-Grid work over different grids. So when you change the value of a global variable and a other grid uses a global variable with the same name the value will be changed there too. This might cause that toggling switches on other grids might appear broken.
Better pass parameters to the function, or, if you don't know how to do that, give the global variables unique names

3) I'm moving this topic to the SDK-Development section
Addihash
Administrator
 
Posts: 232
Joined: 2. Feb 2015, 14:35

Re: Can Someone At Roccat Give This a Quick Test?

Postby Third » 12. May 2015, 14:26

Much thanks for the speedy reply as always.

1) so you think the "click" is a error in the .wav files themselves? Or some other file? When I play them individually, the "click" is not present. And it's not present on my dev rig when played individually or thru the Grids (actually, these are the same .wavs used in my v3 and no one reported any issue in the past month). But I can re-do them if you think that's the root of the problem.

One step closer to publication in any event.

2) I'll add unique names to my global variables to avoid conflict. I did a pass thru all my files to make them unique as to not mess up anyone else's bits that might have the same name.

Thanks so much for the reply !

Third
Third
 
Posts: 41
Joined: 20. Apr 2015, 21:58

Re: Can Someone At Roccat Give This a Quick Test? [RESOLVED]

Postby Third » 12. May 2015, 16:30

OK, all squared away and confirmed working on other machines. Converted all original .wav to .mp3 and "mystery click" is now gone.

Thanks again for all the help !


Third
Third
 
Posts: 41
Joined: 20. Apr 2015, 21:58


Return to Power-Grid SDK

Who is online

Users browsing this forum: No registered users and 1 guest

cron